Re: Sorry to bother you...

Shaw Terwilliger (
Thu, 24 Jun 1999 09:36:33 -0500

On Mon, Jun 21, 1999 at 06:41:27PM -0500, Wade Maxfield wrote:
> I'm running Mandrake 5.3, based on redhat 5.2. The AbiWord you have as
> an RPM in your download is dynamically linked, and refuses to install in
> Mandrake 5.3.
> In addition, the libraries the rpm installation ask for are not
> obviously found in the redhat mirrors. libgdk-1.2 is not found under
> libgdk*.rpm or gdk*.rpm. libglib is obviously glib. libgmodule is who
> knows what. libgtk is obviously gtk. I'm even having trouble installing
> the libraries I find due to interdependencies.
> Would it be too much trouble to either 1) create a statically linked
> binary, or 2) put links to the required libraries for those who have older
> or incomplete installations?

Well good news for ya. :) There is a statically linked binary, just
download it from the same place you got the RPM (assuming you got
it from The statically
linked version is available as a .tar.gz package with a shell script

Also, we have libraries which should satisfy Mandrake Linux's requirement
for glib, gmodule (it's part of glib) and gtk. Check out[redhat] for RPMs.
You might try grabbing the needed RPMs from the libraries section
and see if the RPM AbiWord package installs on your machine. If it doesn't,
send me a note with all the gory details and give the static
binary a shot.

Shaw Terwilliger

This archive was generated by hypermail 1.03b2.