From AbiWiki

Jump to: navigation, search

Missing libglib-2.0-0.dll File

Why do I receive an error message that says "[t]his application has failed to start because libglib-2.0-0.dll was not found. Re-installing the application may fix this problem"?

  • This error message may also be caused by installing a newer version of AbiWord over an older one that had plugins installed. The best method of fixing this is to completely uninstall and reinstall AbiWord. Remember, the recommended method of upgrading is to uninstall beforehand and not to overwrite the previous version.
  • This is also true of the error: "The dynamic link library {dll_name} could not be found in the specified path {default_path}"
    • This is for the following DLLs:
      • iconv.dll
      • intl.dll
      • libglib-2.0-0.dll
      • libgobject-2.0-0.dll
      • libgsf-1-1.dll
      • libxml2.dll.
  • Note: it is not recommended to search for the plugins individually, because the versions found may not match the versions used with AbiWord. To guarantee the same versions, use the "Download glib 2.4" option or manually download the DLL archives from above. Also, disabling plugins from the Tools > Plugins dialog will not fix the errors as the offending plugins arent loaded due to the missing dependencies.
Personal tools