RE: Big wv/LibOLE2 patch

Subject: RE: Big wv/LibOLE2 patch
From: James Montgomerie (
Date: Fri Jun 02 2000 - 04:29:30 CDT

> -----Original Message-----
> From: James Montgomerie
> Sent: 02 June 2000 10:17
> > I have to agree. I started importing a killer word document with tons of
> > tables, lines, OLE stuff at about 11:20. I went to give a
> lecture at 12:00
> > and it was still going. I came back from the lecture and the import has
> > completed. It worked! Of course all the table OLE stuff has gone but
> > anywhere there was text to be found, wv had managed to suck it
> out of the
> > file. Also on another file that crashed abi before, now I get a "bogus
> > document" warning and no crash.
> As Justin says, it certainly shouldn't be taking that long. I don't think
> there's a bugzilla bug about the 'apparently infinitely looping'
> documents -
> perhaps you could make one and post this document somewhere
> web-accessible?

Looks like I'm now replying to my own posts too :-)

If you've compiled a debug build, but don't start it from a terminal, what
does UT_assert() do? Does it still wait for an 'enter' before continuing,
even though there's no hope of getting one, or does it time-out? If it
times out, that could also explain the long load times, as I've been coming
up against tab and run asserts when importing more convoluted documents
(not, I think, the importer's fault, but something to do with display). I
can post the docs somewhere if anyone's interested.

I agree that it's more likely to be an internal wv fault [though I'm
beginning to think of them as 'word file format faults :-] that's causing
Martin's 'apparently infinitely looping' problem though.


This archive was generated by hypermail 2b25 : Fri Jun 02 2000 - 04:27:55 CDT