Unexplained backward text input occasionally

From: Ryan Thiessen <ryanthiessen_at_gmail.com>
Date: Mon Apr 11 2005 - 04:39:47 CEST


My fiancée has been a happy AbiWord user for many years, as have I.
She continues to have odd problems using AbiWord with text input. I
cannot find any references to this on the internet at all (searched
google, bugzilla, mailing lists), but I'm hoping someone on this
mailing list can give me a clue as to why this is happening to her.

The problem occurs when she is typing normally, but then suddenly the
text starts typing backwards. That is to say, when she is typing in
abiword configured for US english on a us english keyboard, she
expects when she enters text to be on the right of the cursor and that
the cursor will move right after she inputs text. Instead, she enters
text and the cursor stays static, and text appears to the left of the
cursor, effectively entering what she types in reverse.

It's not system dependant, it has occurred on several machines. It's
not distribution dependant, since it's occurred on fedora, debian
woody, and ubuntu. It's not desktop environment dependant, since it
occurs in both WindowMaker and Gnome environments. It happens with a
variety of fonts, and has been intermittant over the course of many
versions for several years. This makes me think it is not a bug, and
instead some sort of key combination she is inadvertantly pressing
that is triggering this behaviour.

So, do any of you have an idea what she is doing to trigger this? Or
any way that she can alter what she does to debug what is going on so
she can prevent the problem from happening?

-Ryan Thiessen-
To unsubscribe from this list, send a message to
abiword-user-request@abisource.com with the word
unsubscribe in the message body.
Received on Mon Apr 11 04:40:18 2005

This archive was generated by hypermail 2.1.8 : Mon Apr 11 2005 - 04:40:19 CEST