Re: Pango

From: Chris Vine (
Date: Sat Nov 15 2003 - 20:13:08 EST

  • Next message: Ted Parks: "Re: Pango"

    On Sunday 16 November 2003 1:08 am, Ted Parks wrote:
    > I am trying to build Abiword-2.0.1-2 on an i686 running RedHat 8.0. When
    > I try to build Pango so that I can build Abiword, I get the following
    > message, even after I have built GLIB-2.2.3.
    > checking for GLIB - version >= 2.1.3...
    > *** 'pkg-config --modversion glib-2.0' returned 2.2.3, but GLIB (2.0.6)
    > *** was found! If pkg-config was correct, then it is best
    > *** to remove the old version of GLib. You may also be able to fix the
    > error *** by modifying your LD_LIBRARY_PATH enviroment variable, or by
    > editing *** /etc/ Make sure you have run ldconfig if that is
    > *** required on your system.
    > *** If pkg-config was wrong, set the environment variable PKG_CONFIG_PATH
    > *** to point to the correct configuration files
    > no
    > configure: error:
    > *** Glib 2.1.3 or better is required.
    > What should I do to build Pango so that I can then build Abiword? Is it
    > possible to compile Abiword-2.0-1-2 on RedHat 8.0?

    It looks as if you have both glib-2.2 and glib-2.0 installed. Perhaps one is
    in /usr/lib and another in /usr/local/lib, and the glib-2.0 version is being
    found first by the linker.


    To unsubscribe from this list, send a message to with the word
    unsubscribe in the message body.

    This archive was generated by hypermail 2.1.4 : Sat Nov 15 2003 - 20:12:44 EST