gcc 3.3.1 and 1.99.4

From: Michael A. Peters (mpeters@mac.com)
Date: Sun Aug 24 2003 - 17:48:02 EDT

  • Next message: Dom Lachowicz: "Re: gcc 3.3.1 and 1.99.4"

    I run an rpm bootstrapped "LFS" (Linux From Scratch).
    I had AbiWord 1.99.2 working very well - and then in July, my hard drive
    (IBM Deathstar) died.

    I've now rebuilt the system, using the same rpm spec files that I used
    previously - only major difference is I used gcc 3.3.1 (where as before
    I used 3.2.3).

    Same version of software for most other things (such as gnome) - AbiWord
    1.99.4 will not build :(

    It fails at:

    In file included from
                     from /usr/include/libgnomeui-2.0/gnome.h:7,
                     from ev_UnixToolbar.cpp:55:
    /usr/include/gnome-vfs-2.0/libgnomevfs/gnome-vfs-file-size.h:48: error:
    ISO C++
       does not support `long long'
    /usr/include/gnome-vfs-2.0/libgnomevfs/gnome-vfs-file-size.h:49: error:
    ISO C++
       does not support `long long'
    ev_UnixToolbar.cpp: In member function `bool
    ev_UnixToolbar.cpp:999: warning: unused variable `bool bResult'
    make[4]: *** [ev_UnixToolbar.o] Error 1
    make[4]: Leaving directory

    This part:

    ISO C++
       does not support `long long'

    makes me think this is a compiler issue, and that it therefore isn't
    uniq to my setup, and that someone who is more knowledgeable in C++ than
    I has seen it with the newer gcc, and patched it.

    But I can't find the patch - I searched the mail archives (via google)
    and bugzilla.

    Anyone have a patch?
    I really don't want to install a second gcc. And I really like using

    To unsubscribe from this list, send a message to
    abiword-user-request@abisource.com with the word
    unsubscribe in the message body.

    This archive was generated by hypermail 2.1.4 : Sun Aug 24 2003 - 17:59:46 EDT