Re: patch -- win build embeds a perl interpreter

Subject: Re: patch -- win build embeds a perl interpreter
From: Michael D. Pritchett (
Date: Thu Sep 06 2001 - 13:43:34 CDT

On 6 Sep 2001, [ISO-8859-1] Joaquín Cuenca Abela wrote:

> of course, only if it's build with ABI_OPT_PERL=1.
> P.S.: I've done some little changes to ut_PerlBindings in linux and I've
> not rechecked that it still builds in windows, so maybe windows perl
> build will be a bit broken... :) I don't think so, and anyway now it
> should be easy to fix if it's broken.
> --

Joaquin -

Okay - I am working from the stuff in CVS. I have ActiveState Perl Build
623 v5.6.0. It has been included in my path.

I checked out and built with ABI_OPT_DEBUG=1 ABI_OP_PERL=1 and ran into my
first problem. Unable to include EXTERN.h. So I added to my include path
the perl/lib/CORE directory. Just for fun I added the it to my lib

It complained "No libary found for '-lperl' and then had a bunch of
unresolved externals for ut_PerlBindings.obj. What do I need to do to get
this working for Win32?


Michael D. Pritchett

This archive was generated by hypermail 2b25 : Thu Sep 06 2001 - 13:55:20 CDT