Re: abiword dies before splash screen.

Subject: Re: abiword dies before splash screen.
From: Rui Miguel Seabra (
Date: Mon Nov 12 2001 - 03:15:09 CST

On Mon, 2001-11-12 at 05:55, Martin Sevior wrote:
> Hi Folks,
> I just finished making a gtk build and abiword dies before the
> splash screen appears with the error:
> DEBUG: XDisplay [:0], current X font path count 1, AW path count 1,
> subdircount 5
> DEBUG: adding "/home/msevior/abidir/AbiSuite/fonts/" to font path
> DEBUG: --- setting X font path (2 items)
> DEBUG: fontpath[0]: "unix/:7100"
> DEBUG: fontpath[1]: "/home/msevior/abidir/AbiSuite/fonts/"
> DEBUG: -------------------------------------------------
> Gdk-ERROR **: 86
> serial 9 error_code 86 request_code 51 minor_code 0
> Something to do with fonts. I have a working xfs that works fine with our
> rpm on a redhat 7.1 system.
> I'm not very good with X trickery. For those that are, please fix this
> ASAP. This is an abiword bug not an X configuration bug.


It is a bug in that we assum that X handles it's fonts.
It is not a bug in that the user should have in his X configuration
(even though he uses an x font server):

Add to XF86Config-4 (in Section "Module"):
        Load "bitmap"
        Load "freetype"
        Load "speedo"
        Load "type1"

And all will work.

Hugs, rms

+ No matter how much you do, you never do enough -- unknown
+ Whatever you do will be insignificant,
| but it is very important that you do it -- Ghandi
+ So let's do it...?

This archive was generated by hypermail 2b25 : Mon Nov 12 2001 - 03:20:46 CST