Re: fscking GAL.

Subject: Re: fscking GAL.
From: Dom Lachowicz (
Date: Thu Jul 26 2001 - 08:47:33 CDT

Quoting Martin Sevior <>:

> My latest rpms have the crash on color-picker problem. These are
> built with latest ximinian gnome which has gal versions 0.8 and 0.9. My
> laptop does not have this problem, which has GAL versions up to
> 0.7. However my rpm's also seem to require gal version 0.3!!
> If I delete gal version 0.3 from my system even a freshly compiled gnome
> build refuses to run, complaining they need GAL version 0.3. I've looked
> and I can't find any reference to GAL version 0.3 in Abiword. Do have
> any
> idea what is happenning?

Somewhere in the evolution of GAL, the "color-changed" prototype (stupidly?)
changed from:

(ColorCombo *, GdkColor *)


(ColorCombo *, gboolean, GdkColor *)

where the gboolean is (99.9% of the time) often false(0). So we'd end up
treating a gboolean as a null GdkColor and dereference it... BOOM! That is,
until I changed the code. So to fix, you just need to compile and link against a
newer version of GAL.


This archive was generated by hypermail 2b25 : Thu Jul 26 2001 - 08:47:40 CDT