Re: commit -- Re: does expat/libtool combo work on Win32?

Subject: Re: commit -- Re: does expat/libtool combo work on Win32?
From: Michael D. Pritchett (
Date: Thu Feb 15 2001 - 11:51:55 CST

Paul -

I have been sitting on the sideline too long on this issue. I too had a lot
of problems getting the system to Just Work(TM), and was building
Makefile.abi when finally Thomas Briggs and company were able to correct the
CVS stuff and get it to Just Work(TM).

That said here is my basic explaination on getting the thing to build in
under Windows:

Clean CVS checkout.
Get a command prompt.
Run VCVARS32.bat that sets up the path to the compiler.
Go to abi dir.
Type make.

All should work.

Obviously, there was something askew with your last build. I am not going
to go into the details. Suffice to say it didn't work. My suggestions are
to erase expat/Makefile and expat/config.cache. Then go to the abi
directory and type make.

The following is why - under the abi build system:
./configure is run only when there is not a Makefile in the expat directory.
(go ahead a delete an existing Makefile) As ./configure uses a config.cache
file that it creates from a previous run, I recommend deleting the
config.cache file too so a new cache is built from scratch.

If you want to run ./configure from scratch - the abi ./configure command is
as follows:
$(EXPAT_PLATFORM_DEFS) ./configure --disable-shared --enable-static;
which translates for windows to:
CC=cl.exe CONFIG_SHELL=bash.exe
./configure --disable-shared --enable-static;
Note that this will not work unless cl.exe is in the path (the reason for
running VCVARS32.bat in the first place).


Michael D. Pritchett

This archive was generated by hypermail 2b25 : Thu Feb 15 2001 - 12:03:23 CST