Problems adding new source files

Subject: Problems adding new source files
From: Andrew Dunbar (
Date: Wed Apr 11 2001 - 01:26:58 CDT

Hi. I'm working on EncodingManager support for Windows
but so far I'm having problems getting my new files to link. I think
there is something in the Makefiles
and/or the config directory that I am missing.

Here are the error messages:

make[4]: Entering directory
Building with [LicensedTrademarks:Off Debug:On BiDi:Off Pspell:Off].
MSVCRTD.lib(cinitexe.obj) : warning LNK4098: defaultlib "msvcrt.lib"
conflicts with use of other libs; use /NODEFAULTLIB:library
libAbiXAp_s.lib(xap_Win32App.obj) : error LNK2001: unresolved external
symbol "public: __thiscall
i386_DBG\bin\AbiWord.exe :
 fatal error LNK1120: 1 unresolved externals

And here are the changes I've made to the Makefiles:

Index: src/af/xap/Makefile
RCS file: /cvsroot/abi/src/af/xap/Makefile,v
retrieving revision 1.59
diff -r1.59 Makefile

$(OBJDIR)/xap_$(ABI_FE)DialogHelper.$(OBJ_SUFFIX)       \
Index: src/af/xap/win/Makefile
RCS file: /cvsroot/abi/src/af/xap/win/Makefile,v
retrieving revision 1.30
diff -r1.30 Makefile
<                       xap_Win32Module.cpp
>                       xap_Win32Module.cpp                     \
>                       xap_Win32EncodingManager.cpp

Please let me know what else I need to do. Thanks.


__________________________________________________________________ Get your free Australian email account at

This archive was generated by hypermail 2b25 : Wed Apr 11 2001 - 00:33:49 CDT