Re: Segfault opening footer.abw

Subject: Re: Segfault opening footer.abw
From: Jonathan Turner (
Date: Sun Nov 12 2000 - 08:53:31 CST

Sam TH wrote:

> On Sun, Nov 12, 2000 at 02:05:27AM -0800, Matt Brubeck wrote:
>> I get a segfault when I try to open test/wp/footer.abw. This happens
>> under Windows and Linux.
>> fl_BlockLayout::getNewLine() is trying to get a Container from a
>> HdrFtrSectionLayout. The relevant functions in fl_HdrFtrSectionLayout
>> simply assert and return NULL whenever they are called. The code doesn't
>> check for this, and tries to use the NULL pointer.
>> I tried to fix it, but don't know the code well enough (yet). I filed
>> bug #1053:
> Some more info on this. It turns out that the problem stems from having
> text in the footer. Multiple fields, or single fields are not a problem,
> but any text causes that segfault. This happens on both headers and
> footers, and is irrespective of other document content. In fact, images
> in headers/footers works, as long as there is no text.
> The next step is figuring out when this broke. It appears to have broken
> more than one week ago, but I'll let people know what I find out.
> This also gives me an idea for a regression test suite. `yes | abiword`
> must not crash opening any of the documents in test/wp/. I'll set up
> the nightly build script to do this eventually.
> sam th
> GnuPG Key:

I don't know if this goes along with the same thing... but I tried to
open Program.doc (from ) but all I
got was question marks. Even though kword gave me errors, I could still
view the document.

Sorry... I'm a newbie as far as Abi goes, so I don't know if this was
already covered, if so, please excuse me.


This archive was generated by hypermail 2b25 : Sun Nov 12 2000 - 08:52:59 CST