Subject: Re: UT_Pair
From: Mike Nordell (email@example.com)
Date: Fri Nov 10 2000 - 17:03:12 CST
Vlad Harchev wrote regarding my suggested changes to UT_Pair:
> Sorry for giving it stupid name. Just add
> typedef UT_Pair UT_Tuple_string_string;
> or something like that in ut_pair.h and save your time from rewriting it.
Good idea, but It would still leave a semantics problem in the class and the
class name itself.
> but since human resources of AW
> development project are that constrained, it's more optimal to use human
> time for something else (e.g. fixing user-visible bugs).
True. And it would be the optimal solution to be able to get everyone
working in their specific area of expertise to create the most possible
functionality in the least possible time with the experts overlooking all of
Fortunately, we don't have that development model.
I myself decides where I want to put my time into AW. Yes, human resources
are finitie, but that doesn't void the fact that it's still the contributors
(my) time that gets "wasted". This class had a *very* misleading name, and I
suggested a fix for it. The fix is now 95% complete, and I would have done
*no* (I think) other meaningful work for AW anyway during this time. Sure I
could have checked out bugzilla, but this "bug" struck me in the face while
trying to get Win32 spell to function again. What I did was one of the bases
for XP: fix it when you see it. This is nothing to complain about, this is
something to embrace. If noone fix problems when they see them, we soon have
When I get time I *will* start to shoot down those pesky bugzilla things one
after one again, but until I that happens I might as well fix what I find
when I find it. You are of course free to disagree, but that doesn't change
the fact that I'm free to try to improve the maintainability of the code.
This archive was generated by hypermail 2b25 : Fri Nov 10 2000 - 17:01:46 CST